Developer Workstation Installation

Open 'Developer Workstation Installation' wizard, choose your scenario to see more provider-related information of the installation manual.

Software Requirements

Sana Commerce requires some software to be installed.
Administrator rights might be required to install the missing components. 
The following software is required to deploy Sana Commerce on a server environment:
  • MS Windows XP Professional Edition with Service Pack 3 or later, Windows Vista Business Edition, Ultimate Edition, or Enterprise Edition with Service Pack 1 or later, MS Windows 7 Professional, Ultimate, or Enterprise, MS Windows Server 2003 with Service Pack 2 or later, MS Windows Server 2003 R2 with Service Pack 2 or later, MS Windows Server 2008, Windows Server 2008 R2, MS Small Business Server 2003 R2 with Service Pack 2 or later, MS Small Business Server 2008 or later, MS Windows Essential Business Server 2008, Standard or Premium.
    Sana Commerce supports both 32 bit and 64 bit versions of the operating systems;
  • MS Windows 2003 support tools (only required for MS Windows Server 2003 and MS Windows Server 2003 R2);
  • MS .NET Framework 4.0 (can be downloaded here);
  • Microsoft SQL Server 2005 with Service Pack 2 or later, SQL Server 2008 (R2) Express, Workgroup, Standard, or Enterprise.  Please note that the Express editions can only be used if the database size is under 4GB;
  • MS SQL Management Studio 2005 or MS SQL Management Studio 2008 Express, Workgroup, Standard, or Enterprise edition;
  • MS IIS 6, 7 or 7.5. The FTP service is a required component. The SMTP service might also be required when no alternative SMTP server is available.