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Sana Commerce 9.3
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DI Server Not Found

 NOTE

Sana for SAP Business One 9.3 does not support patch levels 10 and 11 for both, HANA and SQL databases due to a known SAP bug in these patch levels. This bug in the patch levels 10 and 11 for SAP Business One 9.3 causes frequent connection failures between Sana and SAP Business One.

SAP fixed this issue in patch level 12. If you plan to upgrade your SAP Business One system, make sure that you are using the correct patch level.


Component

Data Interface Server (DIS)

Symptom

Sana cannot connect to SAP Business One.

When you click "Test connection" on the "ERP connection" page in Sana Admin, the following error is shown:

"DI server not found."

Cause

There may be several reasons for this problem.

  1. SAP Business One 9.3 patch levels (PL) 10 and 11.
  2. Wrong configuration of permissions for the SAP Business One DI Server.

Solution

  1. SAP Business One 9.3 patch levels (PL) 10 and 11 can cause frequent connection failures between Sana and SAP Business One. Another noticeable symptom is that it is not possible to restart the DI Server using SAP Business One Service Manager.



    This is a known issue and it was fixed by SAP in patch level 12. Therefore, if you have patch level 10 or 11, upgrade your SAP Business One 9.3 system to patch level 12 or higher.

    For more details about this issue, check this link. You will need to log in with your S_User account.

  2. If the issue is not because of the patch level, then check if the permissions for the SAP Business One DI Server are configured correctly. For more information, see "DI Server Permissions".
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