Knowledge BaseTroubleshooting

Troubleshooting

The Images Are not Shown in the Backoffice

Problem:
The images are not shown in the backoffice.

Symptoms:
The images are not shown in the backoffice when you add them to the content pages, configure themes or other backoffice options which require the images or you open the images in the Server explorer.

Cause:
Possible reasons:
  • Incorrect path to the image folders;
  • The wildcard is not configured;
  • The user who runs the application pool for the backoffice does not have the 'read' right to the folder where the images are stored.

Solution:

  • Check in the 'web.config' file of the backoffice if the path to the image folders is the same as where the images are stored. More detailed information can be found in the 'Configure Server Explorer' chapter.
  • Check if the wildcard is configured in IIS for correct image handling work. More information about how to configure the wildcard can be found in the 'Configure IIS' chapter.

    In the wildcard configuration check the path to the DLL in the 'Executable' field. The path differs depending on the versions of .Net Framework and Windows installed on the server. For more information read the note in the end of the 'Configure IIS' chapter.

  • Check if the user who runs the application pool for the backoffice have 'read' right on the folder where the images are stored in order to prevent problems with showing the images in the backoffice.

Related to:
All scenarios

Knowledge BaseTroubleshooting